vSphere 6.0 Update 3 – Client Integration Plugin link broken

Edit_01: As quickly as I post this it seems that VMware have fixed the broken link. Happy Days! Thanks to Mark Brookfield, a.k.a. VirtualHobbit for the heads-up 🙂 Apparently the CIP installer is also in the main vSphere .iso ….although I can’t find it in there myself.

I started the update process this morning to get our environment upgraded to vSphere 6.0 Update 3. As is best practice, I followed the official Upgrade Path KB article on VMware’s website and upgraded my vCenter instance first (we don’t have any vRA or NSX).

The vCenter Server management portal identified the required update, processed it, then rebooted itself. A few minutes later I went to login to vCenter and hoped to use SSO to sign in, as I always do, but was presented with what you see in Figure 1 instead.

sso_upgrade_plugin
Figure 1

Note the “Upgrade Client Integration Plugin” in the bottom left. OK, so let’s click that and upgrade…..nope 😦 Error!

An error occurred while processing your request.
Reference #132.4d8b1bb8.1488203316.17e2daae

The exact link tries to hit:
http://vsphereclient.vmware.com/vsphereclient/VMware-ClientIntegrationPlugin-6.0.0-4911605.exe

This is clearly broken. Manual searching on VMware’s website for this version of the plugin was to no avail.

I suspect, therefore, that we’ll need to wait until VMware fix the link before we can use SSO again for vCenter 6.0 U3? Comments welcome 👍